Pantalla_de_error_Synaptic

Si tenemos problemas con la instalación de algún paquete que no termina de instalarse correctamente, lo primero que deberíamos intentar es usar Synaptic para solucionarlo desde el entorno gráfico, puede que sea unpaquete Roto que podemos eliminar y si esto no funciona solo nos queda ejecutar algunas ordenes en la terminal para reparar los problemas de dependencias.

Explico las órdenes a ejecutar en la terminal para reparar este paquete roto o mal instalado:
Primero lo más simple, estas son las ordenes que utiliza synaptic para reparar en modo gráfico, sino conseguiste nada, yo pasaría estas órdenes por ver los que detalles te da al lanzar los mismos en la terminal o shell.

 

sudo dpkg –configure -a
sudo apt-get -f install

Podemos intentar también forzar la instalación del paquete con el flag force-overwrite, por ejemplo:

sudo dpkg -i –force-overwrite /var/cache/apt/archives/libcupsys2-dev_1.1.23-3_i386.deb

Podemos limpiar la cache de apt de todos aquellos paquetes, que ya no pueden descargarse:

sudo apt-get autoclean

Intentar borrar el paquete si sabemos el nombre concreto con:

sudo apt-get autoremove paquete o sudo apt-get –purge remove paquete

Y si todo ello no resulta, ya solo nos queda probar la eliminación del paquete seriamente dañado con:

1) Forzamos

sudo dpkg –purge –force-remove-reinstreq

y si aun asi, no funciona, entonces probaríamos:
a.- Ejecutamos

dpkg –listfiles

y buscamos cada fichero que se instalo, de los que dan problemas, para a continuación buscarlos y eliminarlos.
b.- Editar el archivo:

sudo nano /var/lib/dpkg/status

Eliminar la sección del paquete seriamente dañado. Hacer una copia de seguridad antes de editar el archivo:

cp /directorio/archivo /home/tu_usuario/copias_archivos

c.- Editar el archivo:

sudo nano /var/lib/dpkg/available

Eliminar la sección del paquete seriamente dañado. Hacer una copia de seguridad antes de editar el archivo.
Recordad que, usar diferentes fuentes de repositorios a veces, puede causarnos problemas de este tipo y que lo más recomendable es siempre usar fuentes oficiales para evitarnos estos problemas.

Un comentario »

  1. aldobelus dice:

    Hola Eddy. En tu primera opción (dpkg –configure -a) la página no ha escrito bien los guiones, que son dos. Cuando los copias y pegas en Terminal, no los diferencia, creando un error.
    Saludos

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s